Vous avez un iPhone 5 ? Mettez-le à jour à cause du GPS

J’en avais parlé il y a quelques mois, une évolution du protocole GPS va empêcher la localisation par satellite de fonctionner sur d’anciens appareils iOS à partir du 3 novembre (demain). Apple a corrigé l’OS de quelques appareils, mais visiblement, il faut mettre à jour l’iPhone 5.

Pour résumer : il faut installer iOS 10.3.4 pour l’iPhone 5 et l’iPad “4” cellulaire. Ou iOS 9.3.6 pour iPhone 4S, iPad “3” cellulaire, iPad 2 cellulaire et iPad mini cellulaire. Il n’y a pas de MAJ pour l’iPhone 3G, 3GS ou 4, ni pour l’iPad cellulaire, ni pour l’iPhone 5c, qui doit avoir une puce GPS corrigée. Le point étonnant, c’est qu’Apple indique que l’iPhone 5 a un problème spécifique.

Visiblement, l’iPhone 5 utilise la localisation pour la gestion de l’heure, et l’arrivée du bug – demain – empêchera la mise à jour automatique d’iOS 10. De plus, iCloud, la messagerie et la navigation devraient aussi poser des soucis. Assez bizarrement, Apple met uniquement en avant l’iPhone 5 et pas les autres modèles. Je ne connais pas les détails techniques, mais soit Apple se concentre sur le modèle le plus récent, soit les autres appareils (iPhone 4S, iPad cellulaires) fonctionnent différemment.

En tout cas, si vous avez un iPhone 5 qui n’est pas à jour (sous iOS 10.3.2 ou avant, donc), il faut mettre à jour en OTA aujourd’hui. Sinon, la seule solution passera par iTunes (ou le Finder sous macOS Catalina). Vous êtes prévenus.

Au passage, je testerais pour vous les problèmes qui peuvent survenir avec un appareil qui n’est pas à jour…