Impossible de vérifier cette copie de l’application Installer OS X Mavericks

Récemment, j’ai dû installer OS X Mavericks sur une machine et j’ai eu un message bizarre : « Impossible de vérifier cette copie de l’application Installer OS X Mavericks. ». L’erreur est similaire à celle de High Sierra, mais le problème ne vient pas d’une date erronée, elle vient justement du fait que la date est correcte.

TL;DR : Mavericks ne s’installe pas en 2018. Il faut mettre une date plus ancienne.

Le message

Le message exacte est : « Impossible de vérifier cette copie de l’application Installer OS X Mavericks. Elle peut avoir été endommagée ou altérée au cours de l’installation. ». Le problème existe aussi avec d’autres systèmes (par exemple macOS High Sierra) mais la raison n’est pas la même. Avec Mavericks, le problème se pose quand le Mac possède la bonne date (par exemple août 2018, comme quand j’écris ce sujet). Donc au lieu de devoir mettre le Mac à la bonne date, il faut le mettre à une date antérieure. La solution la plus simple est d’utiliser la date de sortie de l’OS : 22 octobre 2013.

Dans l’interface d’installation, il faut donc lancer le Terminal (Utilitaires -> Terminal) et taper la commande suivante.

date 1022200013

La syntaxe exacte est date MMJJHHmmAA mais j’ai déjà indiqué une date valable (MM pour le mois, JJ pour le jour, HH pour l’heure, mm pour les minutes et AA pour l’année).

La solution

Une fois la date changée, OS X Mavericks devrait s’installer et reprendre la bonne date une fois installé. J’ai effectué rapidement quelques tests, et c’est visiblement le seul OS qui n’accepte pas de s’installer en 2018 : ça fonctionne avec Lion, Mountain Lion, Yosemite et El Capitan.

Ca fonctionne